Opened 9 months ago

Last modified 4 days ago

#1820 new Aufgabe

Update Smarty

Reported by: Tomcraft Owned by: somebody
Priority: normal Milestone: modified-shop-2.0.6.0
Component: Shop Version: trunk

Description (last modified by Tomcraft)

Wir setzen derzeit Smarty 3.1.33 ein mit der Korrektur der Smarty replace Funktion, siehe Ticket #1627.
Aktuell ist bereits Smarty 3.1.36 verfügbar und der Fehler wurde immer noch nicht behoben, da denen ein Testcase fehlt, siehe: problems with smarty_mb_str_replace PHP >= 7.1

Können wir da nicht nochmal helfen einen Testcase zu erstellen, damit endlich eine offizielle Korrektur in nächste Release mit einfließt und wir Smarty wieder auf den aktuellen Stand bringen können?

Attachments (0)

Change History (3)

comment:1 Changed 9 months ago by Tomcraft

  • Description modified (diff)

comment:2 Changed 4 days ago by FräuleinGarn

Mittlerweile ist Smarty 3.1.38 aktuell und seit 3.1.37 sind Verbesserungen für die Kompatibilität mit Php 8 eingeflossen.

comment:3 Changed 4 days ago by Tomcraft

  • Milestone changed from modified-shop-2.0.7.0 to modified-shop-2.0.6.0

Ich verschiebe das Ticket mal auf Meilenstein 2.0.6.0 aufgrund der PHP8 Kompatibilität.

Add Comment

Modify Ticket

Action
as new
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.