Opened 3 years ago

Closed 3 years ago

#1486 closed Bug/Fehler (fixed)

Attributnummer 0 wird nicht übertragen

Reported by: Viol Owned by: somebody
Priority: normal Milestone: modified-shop-2.0.5.0
Component: Admin Version: trunk

Description (last modified by Tomcraft)

Eine Attributnummer 0 wird nicht übergeben siehe:

Attributnummer 0 wird nicht angezeigt / damit falsche Übertragung zur WAWI Bug ?

h-h-h hat im obigen Link schon eine Lösung gepostet.

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by anonymous

Bezüglich der "Lösung" muss ich mich korrigieren, auch mit der Änderung in der products_attributes_action.php wird die 0 nicht übertragen.

comment:2 Changed 3 years ago by Tomcraft

  • Description modified (diff)
  • Milestone set to modified-shop-2.0.4.1
  • Version set to trunk

comment:3 Changed 3 years ago by Viol

Hallo,

noRiddle hat die Lösung gepostet: Attributnummer 0 wird nicht angezeigt / damit falsche Übertragung zur WAWI Bug ?

Die admin\includes\modules\orders_info_blocks.php muss ab Zeile 197-200 so geändert werden:


if ($model == '') {
                  $model = xtc_get_attributes_model($order->products[$i]['id'], $order->products[$i]['attributes'][$j]['value'],$order->products[$i]['attributes'][$j]['option'], $lang);
                }
                echo ($model != '' ? $attr_model_delimiter . $model : '<br />'); 

Last edited 3 years ago by Tomcraft (previous) (diff)

comment:4 Changed 3 years ago by Tomcraft

  • Milestone changed from modified-shop-2.0.4.1 to modified-shop-2.0.5.0

comment:5 Changed 3 years ago by GTB

  • Resolution set to fixed
  • Status changed from new to closed

In 11704:

fix #1486

Add Comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.